A perhaps final request for help with debugging

Need help with VueMinder Pro or Ultimate? Ask your questions here.
JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

A perhaps final request for help with debugging

Post by JustSomeVMUser » Tue Apr 07, 2020 7:15 pm

Hello. I've posted here before about how VueMinder Pro started being very slow to draw the windows for events or tasks, at least when - and I am unsure I mentioned this before - the window is approximately half the size of my (2560x1440) screen, or larger. Even dragging windows - VueMinder event windows - to resize them seems slow. The problem started some five months ago.

Attempted solutions that failed include: reinstalling VueMinder; exporting all data from VueMinder, removing the data and reimporting it; repairing .net; changing the drive on which the data is stored; reinstalling my (Nvidia) graphics drivers; installing older versions of those drivers. I did find that when performing the problematic operations my GPU (not CPU) usage spiked. My video card: Nvidia

I lack another Windows computer on which to compare another instance of VueMinder, and I lack another video card that I can easily swap in. I can add that my current installation of Windows seems to be in decent shape. (For everything else works, including even an update from Windows 10 1903 to 1909.

I am techy (though more so on Linux than Windows). What I need is help, from someone with relevant knowledge, about how to (further) debug this problem. This is perhaps a similar problem.

Thanks.

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging

Post by JustSomeVMUser » Tue Apr 07, 2020 11:37 pm

JustSomeVMUser wrote:
Tue Apr 07, 2020 7:15 pm
Hello. I've posted here before about how VueMinder Pro started being very slow to draw the windows for events or tasks, at least when - and I am unsure I mentioned this before - the window is approximately half the size of my (2560x1440) screen, or larger. Even dragging windows - VueMinder event windows - to resize them seems slow. The problem started some five months ago.

Attempted solutions that failed include: reinstalling VueMinder; exporting all data from VueMinder, removing the data and reimporting it; repairing .net; changing the drive on which the data is stored; reinstalling my (Nvidia) graphics drivers; installing older versions of those drivers; doing a deep purge of the Nvidia software. I did find that when performing the problematic operations my GPU (not CPU) usage spiked. My video card: Nvidia GT 1030.

I lack another Windows computer on which to compare another instance of VueMinder, and I lack another video card that I can easily swap in. I can add that my current installation of Windows seems to be in decent shape. (For everything else works, including even an update from Windows 10 1903 to 1909.

I am techy (though more so on Linux than Windows). What I need is help, from someone with relevant knowledge, about how to (further) debug this problem. This is perhaps a similar problem.

Thanks.
[Edited to add a bit more detail, including the model of my video card - I'd left that latter detail out, accidentally.]

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging - SOLVED?

Post by JustSomeVMUser » Wed May 27, 2020 4:29 pm

Hopefully, the problem is now solved, after I installed Nvidia's 446.14 drivers, which have just been released.

I can see nothing relevant in the Nvidia release notes - which are always somehow both baroque and lacking in content - except, possibly, this: 'Fixed an issue where the shader cache was sometimes incorrectly purged upon launching an application. [2937218]'. (The numbered bug report at issue seems to this one.) However, I'm holding my breath, in that I have not yet rebooted.

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging

Post by JustSomeVMUser » Fri Jul 17, 2020 7:34 am

The problem was fixed for a while but then, after fiddling with Nvidia drivers in an attempt to get VirtualBox to work, it is now back and indeed possibly worse than before. I will try a completely clean install of the video drivers and a reinstall of VueMinder.

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging

Post by JustSomeVMUser » Fri Jul 17, 2020 8:54 am

I will try a new video card. I have hopes for this because the new card: is AMD, not Nvidia; uses less power than my existing one (and with the existing one I'm pushing the limits of the terrible and not-really-upgradeable Dell power supply that I have).

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging

Post by JustSomeVMUser » Fri Jul 24, 2020 10:10 am

I have installed a new video card. It is AMD rather than Nvidia. It has a lower power requirement (and is slightly weaker than the previous card). Initially, using it I had the same problem with VueMinder. Then the problem stopped. I infer tentatively that when I used the old card there was some sort of problem with caching.

JustSomeVMUser
Posts: 27
Joined: Tue Jan 02, 2018 2:13 pm

Re: A perhaps final request for help with debugging [SOLVED]

Post by JustSomeVMUser » Sun Aug 09, 2020 7:21 am

It was a power-supply problem: my computer was overloaded. I replaced my old, weak and inefficient power supply with a more powerful and more efficient one and the problem has gone away.

User avatar
VueSoft
Dan Chartrand
Posts: 3847
Joined: Sat Aug 23, 2008 12:39 am
Location: St. Louis, Missouri, USA
Contact:

Re: A perhaps final request for help with debugging

Post by VueSoft » Wed Aug 12, 2020 5:57 pm

Thank you for the update. A bad power supply could cause all kinds of strange issues, but is usually something that's difficult to track down. I'm glad you were able to figure out what was causing the problem.
Dan Chartrand, Founder
VueSoft LLC | St. Louis, Missouri, USA

Post Reply